Cannot Update Previous Version

Jan 11, 2012 at 6:59 PM

I had the CRM Manipulation Library installed (ver on CRM 4 and we upgraded to CRM 2011.  Now when I try to update the current dll it gives me the error:  "Plug-in assembly does not contain the required types or assembly content cannot be updated."  Any ideas on what I can do to fix this?  I don't want to unregister the assembly because I have a lot of workflows using the manipulation library.

Jan 17, 2012 at 7:23 PM

Unfortunately the CRM 2011 version uses completely different libraries.  The best thing to probalby do is to create a solution with the CRM 4 assembly in it, export it, replace the DLL with the CRM 2011 version and update the corresponding XML files in the solution (configurations.xml and solution.xml) to reference the proper *version* and public key token:


FullName="ManipulationLibrary, Version=, Culture=neutral, PublicKeyToken=5623ad1c0a16491c"


You may still have to fix some workflows, and I have not tested doing that, but that is what I would try to fix it (I'd still test that first in a staging system or HyperV image, etc.)

Jan 17, 2012 at 7:27 PM

Thanks!  I will give that a try and see what happens.

Jan 18, 2012 at 5:01 PM

That didn't work.  It gives me a cannot insert duplicate key error.  I tried even converting this to a Managed solution for the DLL and incrementing the version, but I still get the same error.  I have a feeling that it has something to do with the function for AddDays and SubDays being changed.  I might try and compile a version of it with the old names for those funtion and see if that works.

Jan 18, 2012 at 5:59 PM

OK.  I tried changing the function names back and that didn't work. 

The best way is to import the new solution that is included in the zip.  Then in the customizations -> Manipulation Library (old version in my case go to each workflow step and click show dependencies.  Then change the version of the step to the new version (in this case 1.1).  Looks like this from technet  In the case of "Add Days To Date" and "Sub Days From Date", you need to just delete that step and change it to use "Add Days" and "Subtract Days".  That seemed to work for me. Once all the workflows are updated, you can delete the old version.

It is nice that they now have the show dependencies.